细水 2007.06.14

漏洞播报

Microsoft IE语言包安装远程代码执行漏洞(MS07-033)

发布日期:2007-06-12
更新日期:2007-06-14

受影响系统:

Microsoft Internet Explorer 7.0
Microsoft Internet Explorer 6.0 SP1
Microsoft Internet Explorer 6.0
Microsoft Internet Explorer 5.0.1 SP4

描述:


BUGTRAQ  ID: 24429
CVE(CAN) ID: CVE-2007-3027

Internet Explorer是一款非常流行的WEB浏览器。

用于负责按需安装Internet Explorer语言包的例程存在竞争条件错误,成功利用此漏洞的攻击者可以完全控制受影响的系统。

如果网页所包含的一些内容是由所安装语言包不支持的语言编写的话,则用户访问了该网页就可以触发这个漏洞,导致内存破坏。攻击者可以通过构建特制的网页来利用该漏洞,当用户查看网页时,该漏洞可能允许远程执行代码。

<*来源:ZDI (http://www.zerodayinitiative.com/)
  
  链接:http://marc.info/?l=bugtraq&m=118168257112542&w=2
        http://secunia.com/advisories/25627/
        http://www.microsoft.com/technet/security/Bulletin/ms07-033.mspx?pf=true
        http://www.us-cert.gov/cas/techalerts/TA07-163A.html
*>

建议:


临时解决方法:

* 禁止安装语言包,将以下文本保存为.reg文件并导入:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\International]
"W2KLpk"=dword:00000000

厂商补丁:

Microsoft
———
Microsoft已经为此发布了一个安全公告(MS07-033)以及相应补丁:
MS07-033:Cumulative Security Update for Internet Explorer (933566)
链接:http://www.microsoft.com/technet/security/Bulletin/ms07-033.mspx?pf=true


您可以随意转载,但必须在显著位置标明 原创链接 和本 版权声明

本文链接: http://www.mcafeefans.com/?p=1410

发表评论

电子邮件地址不会被公开。

:wink: :twisted: :roll: :mrgreen: 8) :-D :arrow: :-o more »

返回页首返回页尾